GetParameterTypeId Method


Parameter Utils Get Parameter Type Id Method

Gets the ForgeTypeId identifying the built-in parameter corresponding to the given BuiltInParameter value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ForgeTypeId GetParameterTypeId(
	BuiltInParameter builtInParam
)

Parameters

builtInParam BuiltInParameter
The BuiltInParameter value.

Return Value

ForgeTypeId
Identifier of the parameter corresponding to the given BuiltInParameter value.
Exceptions
Exception Condition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also