Link |
This class is used to extend the IExternalResourceServer interface with methods to support operations for elements that are LinkTypes.

System Object
Autodesk.Revit.DB LinkOperations
Autodesk.Revit.DB CADLinkOperations
Autodesk.Revit.DB RevitLinkOperations
Autodesk.Revit.DB LinkOperations
Autodesk.Revit.DB CADLinkOperations
Autodesk.Revit.DB RevitLinkOperations
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The LinkOperations type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the LinkOperations |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | SetOnLocalLinkSharedCoordinatesSavedCallback | Sets the callback that will be called when the Revit user saves new shared coordinate settings to a linked document obtained from an IExternalResourceServer. |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |