IdlingEventArgs Class


Idling Event Args Class

The event arguments used by the Idling event.
Inheritance Hierarchy

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class IdlingEventArgs : RevitAPIPreEventArgs

The IdlingEventArgs type exposes the following members.

Properties
Name Description
Public property Cancellable Indicates whether an event may be cancelled by an event delegate.
(Inherited from RevitAPIEventArgs )
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from RevitAPIEventArgs )
Top
Methods
Name Description
Public method Cancel When the event is cancellable, may call the Cancel() method to cancel it.
(Inherited from RevitAPIPreEventArgs )
Public method Dispose
(Inherited from RevitAPIEventArgs )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method IsCancelled Indicates whether the event is being cancelled.
(Inherited from RevitAPIEventArgs )
Public method SetRaiseWithoutDelay Sets the next invocation of the idling event to be called promptly, rather than relying on the default recurrence of idling from the Revit application. For more details see the remarks describing the Idling event.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also