NewSubcategory Method


Categories New Subcategory Method

Add a new subcategory into the Autodesk Revit document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public Category NewSubcategory(
	Category parentCategory,
	string name
)

Parameters

parentCategory Category
The parent category.
name String
The new category name.

Return Value

Category
If successful, the newly created subcategory.
Exceptions
Exception Condition
ArgumentNullException Thrown when the input argument-"parentCategory" or "name"-is .
ArgumentException Thrown when the input argument-"parentCategory"-cannot add subcategory. Thrown when the input argument-"name"-is an illegal name.
InvalidOperationException Thrown when subcategory creation failed.
See Also