Categories New |
Add a new subcategory into the Autodesk Revit document.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

Parameters
- parentCategory Category
- The parent category.
- name String
- The new category name.
Return Value
CategoryIf successful, the newly created subcategory.

Exception | Condition |
---|---|
ArgumentNullException | Thrown when the input argument-"parentCategory" or "name"-is . |
ArgumentException | Thrown when the input argument-"parentCategory"-cannot add subcategory. Thrown when the input argument-"name"-is an illegal name. |
InvalidOperationException | Thrown when subcategory creation failed. |