Categories New |
Add a new subcategory into the Autodesk Revit document.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)


Exception | Condition |
---|---|
ArgumentNullException | Thrown when the input argument-"parentCategory" or "name"-is . |
ArgumentException | Thrown when the input argument-"parentCategory"-cannot add subcategory. Thrown when the input argument-"name"-is an illegal name. |
InvalidOperationException | Thrown when subcategory creation failed. |

public void AssignSubCategory(Document document, GenericForm extrusion)
{
// create a new subcategory
Category cat = document.OwnerFamily.FamilyCategory;
Category subCat = document.Settings.Categories.NewSubcategory(cat, "NewSubCat");
// create a new material and assign it to the subcategory
ElementId materialId = Material.Create(document, "Wood Material");
subCat.Material = document.GetElement(materialId) as Material;
// assign the subcategory to the element
extrusion.Subcategory = subCat;
}