DocumentPreviewSettings Class


Document Preview Settings Class

Contains the settings related to the saving of preview images for a given document.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB DocumentPreviewSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class DocumentPreviewSettings : IDisposable

The DocumentPreviewSettings type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property IsViewUpdateForced Identifies if Revit will update the preview view if necessary.
Public property PreviewViewId The view id that will be used to generate the preview.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the DocumentPreviewSettings
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method ForceViewUpdate Sets Revit to update the preview view if necessary.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method IsViewIdValidForPreview Identifies if the view id is valid as a preview view id.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also