Document |
Contains the settings related to the saving of preview images for a given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The DocumentPreviewSettings type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | IsViewUpdateForced | Identifies if Revit will update the preview view if necessary. |
![]() | PreviewViewId | The view id that will be used to generate the preview. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the DocumentPreviewSettings |
![]() | ForceViewUpdate | Sets Revit to update the preview view if necessary. |
![]() | IsViewIdValidForPreview | Identifies if the view id is valid as a preview view id. |

// Get the document's preview settings
DocumentPreviewSettings settings = document.GetDocumentPreviewSettings();
// Find a candidate 3D view
FilteredElementCollector collector = new FilteredElementCollector(document);
collector.OfClass(typeof(View3D));
Func<View3D, bool> isValidForPreview = v => settings.IsViewIdValidForPreview(v.Id);
View3D viewForPreview = collector.OfType<View3D>().First<View3D>(isValidForPreview);
// Set the preview settings
using (Transaction setTransaction = new Transaction(document, "Set preview view id"))
{
setTransaction.Start();
settings.PreviewViewId = viewForPreview.Id;
setTransaction.Commit();
}
// Save the document
document.Save();