FindSpaceBoundingElementHandle Method


Exporter IFC Find Space Bounding Element Handle Method

Looks up the handle associated to the element and level id from the ExporterIFC's internal cache.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IFCAnyHandle FindSpaceBoundingElementHandle(
	ElementId id,
	ElementId levelId
)

Parameters

id ElementId
The Revit element id to look for.
levelId ElementId
The element level id.

Return Value

IFCAnyHandle
The handle associated to the element and level id. If the id is not found in the cache, an empty handle is returned (HasValue == false).
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also