UpdaterId Class


Updater Id Class

A unique identifier of an Updater
Inheritance Hierarchy
System Object
Autodesk.Revit.DB UpdaterId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class UpdaterId : IDisposable

The UpdaterId type exposes the following members.

Constructors
Name Description
Public method UpdaterId creates an instance of UpdaterId for given AddInId and a given GUID value
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the UpdaterId
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetAddInId AddInId of the UpdaterId
Public method GetGUID GUID value of the UpdaterId
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
UpdaterID used as a key to register and unregister Updaters and UpdateTriggers in Revit application
See Also