Updater |
A unique identifier of an Updater

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The UpdaterId type exposes the following members.

Name | Description | |
---|---|---|
![]() | UpdaterId | creates an instance of UpdaterId for given AddInId and a given GUID value |

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the UpdaterId |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetAddInId | AddInId of the UpdaterId |
![]() | GetGUID | GUID value of the UpdaterId |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

UpdaterID used as a key to register and unregister Updaters and UpdateTriggers in Revit application