External |
This class represents an identifier for geometry from external sources.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The ExternalGeometryId type exposes the following members.

Name | Description | |
---|---|---|
![]() | ExternalGeometryId | Constructs an ExternalGeometryId object holding the given external geometry identifier. |

Name | Description | |
---|---|---|
![]() | Id | External geometry identifier. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the ExternalGeometryId |
![]() | Equals | Determines whether the specified Object is equal to the current Object . (Overrides Object Equals(Object) ) |
![]() | GetHashCode | Gets the hash code. (Overrides Object GetHashCode ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() ![]() | IsValidExternalGeometryId | Checks whether a given string represents a valid ExternalGeometryId or not. |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

Name | Description | |
---|---|---|
![]() ![]() | Equality(ExternalGeometryId, ExternalGeometryId) | Determines whether two ExternalGeometryIds are the same. |
![]() ![]() | Inequality(ExternalGeometryId, ExternalGeometryId) | Determines whether two ExternalGeometryIds are different. |