GetTargetElement Method


Rebar Constraint Get Target Element Method

Gets the Element object (either Host or Rebar) which provides the constraint. Will throw exception if it's a multi target constraint.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Element GetTargetElement()

Return Value

Element
Returns the Element object (either Host or Rebar) which provides the constraint.
Exceptions
Exception Condition
InvalidOperationException RebarConstraint is no longer valid. -or- Multi target constraint. Consider using the indexed version of the method. -or- The RebarConstraint should not be of RebarConstraintType 'ToSurface'.
See Also