Rebar |
Gets the Element object (either Host or Rebar) which provides the constraint. Will throw exception if it's a multi target constraint.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Return Value
ElementReturns the Element object (either Host or Rebar) which provides the constraint.

Exception | Condition |
---|---|
InvalidOperationException | RebarConstraint is no longer valid. -or- Multi target constraint. Consider using the indexed version of the method. -or- The RebarConstraint should not be of RebarConstraintType 'ToSurface'. |