VertexFormat Class


Vertex Format Class

A specification of the format of vertex data contained in a piece of geometry.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.DirectContext3D VertexFormat

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class VertexFormat : IDisposable

The VertexFormat type exposes the following members.

Constructors
Name Description
Public method VertexFormat Constructs the specification of vertex format from a numerical representation.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the VertexFormat
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method IsValid Tests whether the vertex format specification is valid for rendering.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also