ElementCategoryFilter Constructor (BuiltInCategory, Boolean)


Element Category Filter(Built In Category, Boolean) Constructor

Constructs a new instance of a filter to match elements by category, with the option to match all elements which are not of the given category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementCategoryFilter(
	BuiltInCategory category,
	bool inverted
)

Parameters

category BuiltInCategory
The category to match.
inverted Boolean
True if the filter should match all elements which are not of the given category.
See Also