Command |
The base class of the command Executed and CanExecute event arguments.

System Object
System EventArgs
Autodesk.Revit.DB.Events RevitEventArgs
Autodesk.Revit.UI.Events CommandEventArgs
Autodesk.Revit.UI.Events BeforeExecutedEventArgs
Autodesk.Revit.UI.Events CanExecuteEventArgs
Autodesk.Revit.UI.Events ExecutedEventArgs
System EventArgs
Autodesk.Revit.DB.Events RevitEventArgs
Autodesk.Revit.UI.Events CommandEventArgs
Autodesk.Revit.UI.Events BeforeExecutedEventArgs
Autodesk.Revit.UI.Events CanExecuteEventArgs
Autodesk.Revit.UI.Events ExecutedEventArgs
Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

The CommandEventArgs type exposes the following members.

Name | Description | |
---|---|---|
![]() | ActiveDocument | The active document. |
![]() | Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs ) |
![]() | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs ) |
![]() | CommandId | The command id. |

Name | Description | |
---|---|---|
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |