Analytical |
Defines a portion of an Analytical Model for an Element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The AnalyticalModelSelector type exposes the following members.

Name | Description | |
---|---|---|
![]() | AnalyticalModelSelector | Creates a selector for the analytical model geometry. |
![]() | AnalyticalModelSelector(AnalyticalCurveSelector) | Creates a selector for the analytical model geometry. |
![]() | AnalyticalModelSelector(Curve) | Creates a selector based on a specific analytical curve. |
![]() | AnalyticalModelSelector(Curve, AnalyticalCurveSelector) | Creates a selector based on one portion of a specific analytical curve. |

Name | Description | |
---|---|---|
![]() | CurveSelector | The portion of the curve to be selected. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the AnalyticalModelSelector |

This is used to identify the portion of an analytical model of interest to a client. To identify the portion of the analytical model, the client must identify the curve in question, by using one of the following:
- The specific curve within the analytical model.
- The index of the curve within the analytical model.
- The start of the curve.
- The end of the curve.
- The entire curve. This is the default behavior, so this does not need specifying.

public bool GetReferenceData(AnalyticalElement analyticalModelFrame)
{
Curve analyticalCurve = analyticalModelFrame.GetCurve();
if (null != analyticalCurve)
{
// test the stable reference to the curve.
AnalyticalModelSelector amSelector = new AnalyticalModelSelector(analyticalCurve);
amSelector.CurveSelector = AnalyticalCurveSelector.WholeCurve;
Reference curveReference = analyticalModelFrame.GetReference(amSelector);
// test the stable reference to the start point of the curve
amSelector.CurveSelector = AnalyticalCurveSelector.StartPoint;
Reference startPointReference = analyticalModelFrame.GetReference(amSelector);
// test the stable reference to the start point of the curve
amSelector.CurveSelector = AnalyticalCurveSelector.EndPoint;
Reference endPointReference = analyticalModelFrame.GetReference(amSelector);
}
return true;
}