AnalyticalModelSelector Class


Analytical Model Selector Class

Defines a portion of an Analytical Model for an Element.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure AnalyticalModelSelector

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class AnalyticalModelSelector : IDisposable

The AnalyticalModelSelector type exposes the following members.

Constructors
Name Description
Public method AnalyticalModelSelector Creates a selector for the analytical model geometry.
Public method AnalyticalModelSelector(AnalyticalCurveSelector) Creates a selector for the analytical model geometry.
Public method AnalyticalModelSelector(Curve) Creates a selector based on a specific analytical curve.
Public method AnalyticalModelSelector(Curve, AnalyticalCurveSelector) Creates a selector based on one portion of a specific analytical curve.
Top
Properties
Name Description
Public property CurveSelector The portion of the curve to be selected.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the AnalyticalModelSelector
Top
Remarks
This is used to identify the portion of an analytical model of interest to a client. To identify the portion of the analytical model, the client must identify the curve in question, by using one of the following:
  • The specific curve within the analytical model.
  • The index of the curve within the analytical model.
If a specific part of that curve is of interest, the client needs to identify that by specifying one of the following:
  • The start of the curve.
  • The end of the curve.
  • The entire curve. This is the default behavior, so this does not need specifying.
See Also