WireSize Class


Wire Size Class

Represents specific electrical wire size information.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB.Electrical WireSize

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class WireSize : APIObject

The WireSize type exposes the following members.

Properties
Name Description
Public property Ampacity Get ampacity which be used for specifying size, the unit is ampere.
Public property Diameter Get diameter of wire.
Public property InUse Get or set whether the size can be used in sizing.
Public property Size Get size symbol of wire.
Top
Methods
Name Description
Top
Remarks
Wire size is defined based on corresponding wire material type and temperature rating type.
See Also