WireSize Class


Wire Size Class

Represents specific electrical wire size information.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB.Electrical WireSize

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class WireSize : APIObject

The WireSize type exposes the following members.

Properties
Name Description
Public property Ampacity Get ampacity which be used for specifying size, the unit is ampere.
Public property Diameter Get diameter of wire.
Public property InUse Get or set whether the size can be used in sizing.
Public property Code example IsReadOnly Identifies if the object is read-only or modifiable.
(Inherited from APIObject )
Public property Size Get size symbol of wire.
Top
Methods
Name Description
Public method Dispose Causes the object to release immediately any resources it may be utilizing.
(Inherited from APIObject )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
Wire size is defined based on corresponding wire material type and temperature rating type.
See Also