Wire
|
Note: This API is now obsolete.
Represents specific electrical wire size information.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

The WireSize type exposes the following members.

Name | Description | |
---|---|---|
![]() |
Ampacity | Get ampacity which be used for specifying size, the unit is ampere. |
![]() |
Diameter | Get diameter of wire. |
![]() |
InUse | Get or set whether the size can be used in sizing. |
![]() |
IsReadOnly |
Identifies if the object is read-only or modifiable.
(Inherited from APIObject ) |
![]() |
Size | Get size symbol of wire. |

Name | Description | |
---|---|---|
![]() |
Dispose |
Causes the object to release immediately any resources it may be utilizing.
(Inherited from APIObject ) |
![]() |
Equals |
Determines whether the specified object is equal to the current object.
(Inherited from Object ) |
![]() |
GetHashCode |
Serves as the default hash function.
(Inherited from Object ) |
![]() |
GetType |
Gets the
Type
of the current instance.
(Inherited from Object ) |
![]() |
ToString |
Returns a string that represents the current object.
(Inherited from Object ) |

Wire size is defined based on corresponding wire material type and temperature rating type.