ExportLinetypeInfo Class


Export Linetype Info Class

A value used to represent the info stored in the ExportLinetypeTable .
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ExportLinetypeInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExportLinetypeInfo : IDisposable

The ExportLinetypeInfo type exposes the following members.

Constructors
Name Description
Public method ExportLinetypeInfo Constructs a new default ExportLinetypeInfo.
Public method ExportLinetypeInfo(ExportLinetypeInfo) Constructs a new copy of the input ExportLinetypeInfo object.
Public method ExportLinetypeInfo(String) Constructs a new ExportLinetypeInfo using the destination linetype name as input.
Top
Properties
Name Description
Public property DestinationLinetypeName The destination linetype name (the name of the linetype in the exported format).
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ExportLinetypeInfo
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also