IsVertexPointValid Method


Wire Is Vertex Point Valid Method

Checks if the given vertex point can be added to this wire.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsVertexPointValid(
	XYZ vertexPoint
)

Parameters

vertexPoint XYZ
The vertex point.

Return Value

Boolean
True if the vertex point can be added, false if the point cannot be added because there is already a vertex at this position on the view plane (within tolerance).
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
Vertices are projected to the view plane for comparison.
See Also