ParticipatesInWrapping Method


Compound Structure Participates In Wrapping Method

Identifies if a layer is included in wrapping at inserts and ends.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public bool ParticipatesInWrapping(
	int layerIdx
)

Parameters

layerIdx Int32
Index of a layer in the CompoundStructure. The layer index is zero based. It counts from the exterior of wall and from the top of roofs, floors and ceilings.

Return Value

Boolean
If true, then the layer participates in wrapping at inserts and openings. If false, the layer will not participate in wrapping.
Exceptions
Exception Condition
ArgumentOutOfRangeException The layer index is out of range.
Remarks
This method applies only to interior and exterior shell layers.
See Also