SetHookOrientationAngle Method


Rebar Update Curves Data Set Hook Orientation Angle Method

Note: This API is now obsolete.

Sets the termination's rotation angle at end. The angle will be used for both hook and crank. This information is set to the rebar after the API execution is finished successfully.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
[ObsoleteAttribute("This method is deprecated in Revit 2026 and may be removed in a later version of Revit. Please use RebarUpdateCurvesData.SetTerminationRotationAngle instead.")]
public void SetHookOrientationAngle(
	int end,
	double angle
)

Parameters

end Int32
The end of bar. Should be 0 for start or 1 for end.
angle Double
The termination's rotation angle at end. The angle will be used for both hook and crank.
Exceptions
Exception Condition
ArgumentException The given value for angle is not finite
ArgumentOutOfRangeException Invalid end.
See Also