SetOffsetForIntersectingReference Method


Part Maker Method To Divide Volumes Set Offset For Intersecting Reference Method

Sets offset for the intersecting reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetOffsetForIntersectingReference(
	ElementId intersectingReference,
	double offset
)

Parameters

intersectingReference ElementId
The intersecting reference that will be offset.
offset Double
The new offset.
Exceptions
Exception Condition
ArgumentException PartMaker does not use the specified intersecting reference.
ArgumentNullException A non-optional argument was null
See Also