GetPropertySetApplicableEntities Method


IFCParameter Template Get Property Set Applicable Entities Method

Gets the list of IFC entities to which the property set is applicable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public IList<string> GetPropertySetApplicableEntities(
	PropertySetupType propertySetupType,
	string propertySetName
)

Parameters

propertySetupType PropertySetupType
The property setup type.
propertySetName String
The property set name.

Return Value

IList String
The list of IFC entities to which the property set is applicable.
Exceptions
Exception Condition
ArgumentException A property set with the given name is not present in the template.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also