CreateFreeForm Method (Document, RebarBarType, Element, IList(CurveLoop), RebarFreeFormValidationResult)


Rebar Create Free Form(Document, Rebar Bar Type, Element, IList Curve Loop , Rebar Free Form Validation Result ) Method

Note: This API is now obsolete.


Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
[ObsoleteAttribute("This method is deprecated in Revit 2026 and may be removed in a later version of Revit. Please use Rebar.CreateFreeForm(Document doc, RebarBarType barType, Element host, IList(CurveLoop) curves, RebarStyle style) instead.")]
public static Rebar CreateFreeForm(
	Document doc,
	RebarBarType barType,
	Element host,
	IList<CurveLoop> curves,
	out RebarFreeFormValidationResult error
)

Parameters

doc Document
barType RebarBarType
host Element
curves IList CurveLoop
error RebarFreeFormValidationResult

Return Value

Rebar
See Also