Rebar Class


Rebar Class

Represents a rebar element in Autodesk Revit.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB Element
Autodesk.Revit.DB.Structure Rebar

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public class Rebar : Element

The Rebar type exposes the following members.

Properties
Name Description
Public property CanHaveVaryingLengthBars Identifies if a set can have varying length bars or not.
Public property Static member FreeFormAlignedServerGuid Guid used for identifying the external IRebarUpdateServer for computing Aligned Free Form Rebar.
Public property Static member FreeFormSurfaceServerGuid Guid used for identifying the external IRebarUpdateServer for computing Surface Free Form Rebar.
Public property HasVariableLengthBars Identifies if a set has varying length bars or not.
Public property IncludeFirstBar Identifies if the first bar in rebar set is shown.
Public property IncludeLastBar Identifies if the last bar in rebar set is shown.
Public property LayoutRule Identifies the layout rule of rebar set.
Public property MaxSpacing Identifies the maximum spacing between rebar in rebar set.
Public property NumberOfBarPositions The number of potential bars in the set.
Public property Quantity Identifies the number of bars in rebar set.
Public property ReadOnlyParameters When set to true, Rebar will report all its parameters as read only. For example, the method Parameter::IsReadOnly() for all Rebar Parameters will return true. When set to false, the return value of Parameter::IsReadOnly() will not be affected.
Public property ScheduleMark The Schedule Mark parameter. On creation, the Schedule Mark is set to a value that is unique to the host, but it can be set to any value.
Public property TotalLength The length of an individual bar multiplied by Quantity.
Public property Volume The volume of an individual bar multiplied by Quantity.
Top
Methods
Name Description
Public method CanApplyPresentationMode Checks if a presentation mode can be applied for this rebar in the given view.
Public method CanBeMatchedWithMultipleShapes Checks if this Rebar can be matched with multiple Rebar Shapes.
Public method CanSuppressFirstOrLastBar Checks if the first or last bar in rebar set can be hidden in the given view.
Public method CanUseHookType Checks if the specified RebarHookType id is of a valid RebarHookType for the Rebar's RebarBarType
Public method ClearPresentationMode Sets the presentation mode for this rebar set to the default (either for a single view, or for all views).
Public method ConstraintsCanBeEdited

For ShapeDriven Rebar: returns true, if the Rebar element's external constraints are available for editing using the RebarConstraintsManager class. It will return false if Rebar is in Group

For FreeForm rebar: constraints can be edited if there is a valid external server Guid assigned to that Rebar

Public method Static member ContainsValidArcRadiiForStyleAndBarType
Public method Static member CreateFreeForm(Document, Guid, RebarBarType, Element) Creates a free form rebar that can have constraints.
Public method Static member CreateFreeForm(Document, RebarBarType, Element, IList CurveLoop , RebarFreeFormValidationResult ) Obsolete.
Public method Static member CreateFreeForm(Document, RebarBarType, Element, IList CurveLoop , RebarStyle)
Public method Static member CreateFreeForm(Document, RebarBarType, Element, IList IList Curve , RebarFreeFormValidationResult ) Obsolete.
Public method Static member CreateFreeForm(Document, RebarBarType, Element, IList IList Curve , RebarStyle)
Public method Static member CreateFromCurves(Document, RebarStyle, RebarBarType, Element, XYZ, IList Curve , BarTerminationsData, Boolean, Boolean)
Public method Static member CreateFromCurves(Document, RebarStyle, RebarBarType, RebarHookType, RebarHookType, Element, XYZ, IList Curve , RebarHookOrientation, RebarHookOrientation, Boolean, Boolean) Obsolete.
Public method Static member CreateFromCurves(Document, RebarStyle, RebarBarType, RebarHookType, RebarHookType, Element, XYZ, IList Curve , RebarHookOrientation, RebarHookOrientation, Double, Double, ElementId, ElementId, Boolean, Boolean) Obsolete.
Public method Static member CreateFromCurvesAndShape(Document, RebarShape, RebarBarType, Element, XYZ, IList Curve , BarTerminationsData)
Public method Static member CreateFromCurvesAndShape(Document, RebarShape, RebarBarType, RebarHookType, RebarHookType, Element, XYZ, IList Curve , RebarHookOrientation, RebarHookOrientation) Obsolete.
Public method Static member CreateFromCurvesAndShape(Document, RebarShape, RebarBarType, RebarHookType, RebarHookType, Element, XYZ, IList Curve , RebarHookOrientation, RebarHookOrientation, Double, Double, ElementId, ElementId) Obsolete.
Public method Static member CreateFromRebarShape Creates a new shape driven Rebar, as an instance of a RebarShape. The instance will have the default shape parameters from the RebarShape, and its location is based on the bounding box of the shape in the shape definition. Hooks and cranks are removed from the shape before computing its bounding box. If appropriate hooks and cranks can be found in the document, they will be assigned arbitrarily.
Public method DoesBarExistAtPosition Checks whether a bar is included at the specified position.
Public method EnableCrankLengthOverride Enables or disables the ability to override crank lengths for this rebar instance.
Public method EnableHookLengthOverride Enables or disables the ability to override hook lengths for this rebar instance.
Public method FindMatchingPredefinedPresentationMode Determines if there is a matching RebarPresentationMode for the current set of selected hidden and unhidden bars assigned to the given view.
Public method GetAllRebarShapeIds Gets the ids of the RebarShapes elements that defines the shapes of the rebar.
Public method GetBarIndexFromReference Given a reference that represents a part of a bar, this method will return the bar index.
Public method GetBendData Gets the RebarBendData, containing bar and hook information, of the instance.
Public method GetCenterlineCurves A chain of curves representing the centerline of the rebar.
Public method GetCouplerId Get the id of the Rebar Coupler that is applied to the rebar at the specified end.
Public method GetCrankAngledLength Gets the crank angled length at the indicated bar end. If the crank lengths are overriden will return the overriden value. Otherwise will return the value from the RebarBarType for the existing Crank Type.
Public method GetCrankLength Gets the crank length at the indicated bar end. If the crank lengths are overriden will return the overriden value. Otherwise will return the value from the RebarBarType for the existing Crank Type.
Public method GetCrankOffsetLength Gets the crank offset length at the indicated bar end. If the crank lengths are overriden will return the overriden value. Otherwise will return the value from the RebarBarType for the existing Crank Type.
Public method GetCrankRatio Gets the crank ratio at the indicated bar end.
Public method GetCrankStraightLength Gets the crank straight length at the indicated bar end. If the crank lengths are overriden will return the overriden value. Otherwise will return the value from the RebarBarType for the existing Crank Type.
Public method GetCrankTypeId Gets the id of the Crank Type id that is applied to the rebar.
Public method GetEndTreatmentTypeId Get the id of the EndTreatmentType that is applied to the rebar.
Public method GetFreeFormAccessor Returns an interface providing access to free-form properties and methods for this Rebar element.
Public method GetFullGeometryForView Generates full geometry for the Rebar for a specific view.
Public method GetHookOrientation Obsolete.
Returns the orientation of the termination's plane at the start or at the end of the rebar with respect to the orientation of the first or the last curve and the plane normal. The orientation it's the same for both hook and crank.
Public method GetHookRotationAngle Obsolete.
Gets the termination's out of plane rotation angle at the specified end. The rotation angle it's the same for both hook and crank.
Public method GetHookTypeId Get the id of the RebarHookType that is applied to the rebar.
Public method GetHostId The element that contains the rebar.
Public method GetLapLength Gets the lap length that is used for the specified end - 0 for start, 1 for end.
Public method GetMovedBarTransform Returns a transform representing the movement of the bar relative to its default position along the distribution path.
Public method GetOverridableCrankParameters Gets the formula parameter ids defined in the RebarShape family which are associated with crank length, crank offset length, crank straight length and crank angled length parameters.
Public method GetOverridableHookParameters
Public method GetParameterValueAtIndex Get the parameter value for a bar at the specified index.
Public method GetPresentationMode Gets the presentation mode for this rebar set when displayed in the given view.
Public method GetRebarConstraintsManager Returns an object for managing the external constraints on the Rebar element
Public method GetRebarSplice Gets the rebar splice at the specified bar end - 0 for start, 1 for end.
Public method GetReinforcementRoundingManager Returns an object for managing reinforcement rounding override settings.
Public method GetShapeDrivenAccessor Returns an interface providing access to shape-driven properties and methods for this Rebar element.
Public method GetShapeId Returns the id of the RebarShape element that defines the shape of the rebar.
Public method GetSpliceStaggerLength Gets the stagger length that is used for the specified end - 0 for start, 1 for end.
Public method GetTerminationOrientation Gets the orientation of the termination's (e.g. hook, crank) plane at the start or at the end of the rebar with respect to the orientation of the first or the last curve and the plane normal.
Public method GetTerminationRotationAngle Gets the termination's (e.g hook, crank) out of plane rotation angle at the specified end.
Public method GetTransformedCenterlineCurves A chain of curves representing the centerline of the rebar.
Public method HasPresentationOverrides Identifies if this Rebar has overridden default presentation settings for the given view.
Public method HookAngleMatchesRebarShapeDefinition Checks that the hook angle of the specified RebarHookType matches the hook angle used in the Rebar's RebarShape at the specified end of the bar.
Public method IsBarHidden Identifies if a given bar in this rebar set is hidden in this view.
Public method IsCrankLengthOverrideEnabled Returns true if the ability to override crank lengths is enabled for this rebar instance, false otherwise.
Public method IsHookLengthOverrideEnabled Returns True if the ability to override hook lengths is enabled for this rebar instance, False otherwise.
Public method IsRebarFreeForm Returns true if the rebar is free form and false if shape driven.
Public method IsRebarInSection Identifies if this Rebar is cut by the view plane of the given view.
Public method IsRebarShapeDriven Returns true if the rebar is shape driven and false if free form.
Public method IsUnobscuredInView Checks if this rebar element is shown unobscured in a view.
Public method MoveBarInSet This method applies the transformation matrix to the rebar bar at the desired position in the rebar set. If the bar was already moved, the method will concatenate the transformation matrix with the existing movement.
Public method Static member RebarShapeMatchesCurvesAndHooks Obsolete.
Public method Static member RebarShapeMatchesCurvesHooksAndEndTreatment Obsolete.
Public method RemoveSplice Removes the splice relation at the specified end and all the Rebar Constraints involved in splice.
Public method ResetMovedBarTransform Reset the transformation representing the movement of the bar relative to its default position along the distribution path. The moved bar transform will be set to Identity.
Public method SetBarHiddenStatus Sets the bar in this rebar set to be hidden or unhidden in the given view.
Public method SetBarIncluded Sets if the bar at the desired index is included or not.
Public method SetCrankAngledLengthOverride Sets the crank angled length at the indicated bar end as an override value.
Public method SetCrankLengthOverride Sets the crank length at the indicated bar end as an override value.
Public method SetCrankOffsetLengthOverride Sets the crank offset length at the indicated bar end as an override value.
Public method SetCrankRatioOverride Sets the crank ratio at the indicated bar end as an override value.
Public method SetCrankStraightLengthOverride Sets the crank straight length at the indicated bar end as an override value.
Public method SetCrankTypeId Sets the id of the Crank Type to be applied to the rebar.
Public method SetEndTreatmentTypeId Sets the id of the EndTreatmentType to be applied to the rebar. This can be done if and only if the end of the bar on which the end treatment is applied has no RebarCoupler on it, otherwise will throw an exception.
Public method SetHookOrientation Obsolete.
Defines the orientation of the termination's plane at the start or at the end of the rebar with respect to the orientation of the first or the last curve and the plane normal. The orientation it's the same for both hook and crank.
Public method SetHookRotationAngle Obsolete.
Sets the terminitation's out of plane hook rotation angle at the specified end. The rotation angle it's the same for both hook and crank.
Public method SetHookTypeId Set the id of the RebarHookType to be applied to the rebar.
Public method SetHostId The element that contains the rebar.
Public method SetPresentationMode Sets the presentation mode for this rebar set when displayed in the given view.
Public method SetTerminationOrientation Sets the orientation of the termination's (e.g. hook, crank) plane at the start or at the end of the rebar with respect to the orientation of the first or the last curve and the plane normal.
Public method SetTerminationRotationAngle Sets the termination's (e.g hook, crank) out of plane rotation angle at the specified end.
Public method SetUnobscuredInView Sets this rebar element to be shown unobscured in a view.
Top
See Also