CompoundStructureLayer Class


Compound Structure Layer Class

Describes a single layer in a CompoundStructure.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB CompoundStructureLayer

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public class CompoundStructureLayer : IDisposable

The CompoundStructureLayer type exposes the following members.

Constructors
Name Description
Public method CompoundStructureLayer Creates a compound structure layer using default settings.
Public method CompoundStructureLayer(CompoundStructureLayer) Creates a copy of a compound structure layer.
Public method CompoundStructureLayer(Double, MaterialFunctionAssignment, ElementId) Creates a default compound structure layer based on the given width, function and material element id. The priority is initialized with 999.
Top
Properties
Name Description
Public property DeckEmbeddingType Embedding type for structural deck - only for a layer whose function is StructuralDeck.
Public property DeckProfileId The ElementId of the structural deck profile - only for a layer whose function is StructuralDeck.
Public property Function The function of the layer.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property LayerCapFlag Identifies if the layer participates in wrapping at end caps and/or inserts.
Public property LayerId The id of the layer - note that this may be different from the index in the array of layers in a CompoundStructure.
Public property LayerPriority The priority of the layer.
Public property MaterialId Id of the material assigned to this layer.
Public property Width Width of the layer.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the CompoundStructureLayer
Top
See Also