GetTerminationPlaneNormalForBarIdx Method


Rebar Update Curves Data Get Termination Plane Normal For Bar Idx Method

Gets the plane's normal in which the termination (e.g. hook, crank) at end of bar with index barPositionIndex that is currently in Rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public XYZ GetTerminationPlaneNormalForBarIdx(
	int end,
	int barPositionIndex
)

Parameters

end Int32
The end of bar. Should be 0 for start or 1 for end.
barPositionIndex Int32
An index between 0 and (GetNumberOfBars()-1).

Return Value

XYZ
Returns the plane's normal in which the termination (e.g. hook, crank) at end of bar with index barPositionIndex that is currently in Rebar.
Exceptions
Exception Condition
ArgumentOutOfRangeException barPositionIndex is not in the range [ 0, GetNumberOfBars()-1 ]. -or- Invalid end.
Remarks

This method does not take into account the rotation of the bar relative to its default position along the distribution path.

See Also