CreateFromCurves(Document, RebarStyle, RebarBarType, Element, XYZ, IList<Curve>, BarTerminationsData, Boolean, Boolean) Method


Rebar Create From Curves(Document, Rebar Style, Rebar Bar Type, Element, XYZ, IList Curve , Bar Terminations Data, Boolean, Boolean) Method


Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public static Rebar CreateFromCurves(
	Document doc,
	RebarStyle style,
	RebarBarType barType,
	Element host,
	XYZ norm,
	IList<Curve> curves,
	BarTerminationsData barTerminationsData,
	bool useExistingShapeIfPossible,
	bool createNewShape
)

Parameters

doc Document
style RebarStyle
barType RebarBarType
host Element
norm XYZ
curves IList Curve
barTerminationsData BarTerminationsData
useExistingShapeIfPossible Boolean
createNewShape Boolean

Return Value

Rebar
See Also