Light |
This class represents a set of light groups that are used for easier management of various lighting scenarios

System Object
Autodesk.Revit.DB.Lighting LightGroupManager
Autodesk.Revit.DB.Lighting LightGroupManager
Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The LightGroupManager type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | CreateGroup | Create a new LightGroup object with the given name |
![]() | DeleteGroup | Remove the given LightGroup object from the set of LightGroup objects |
![]() | Dispose | Releases all resources used by the LightGroupManager |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetGroups | Get the set of contained LightGroup objects The set of LightGroup objects |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetLightDimmer | Gets the dimmer value for the given light for rendering the given view |
![]() ![]() | GetLightGroupManager | Creates a light group manager object from the given document |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | IsLightGroupOn | Returns true if the given light group is on |
![]() | IsLightOn | Returns true if the given light is on for rendering the given view |
![]() | SetLightDimmer | Sets the dimmer value for the given light for rendering the given view |
![]() | SetLightGroupOn | Turns the given light group on or off for rendering the given view depending on the bool argument |
![]() | SetLightOn | Turns the given light on or off for rendering the given view depending on the bool argument |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |