LightGroupManager Class


Light Group Manager Class

This class represents a set of light groups that are used for easier management of various lighting scenarios
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Lighting LightGroupManager

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class LightGroupManager : IDisposable

The LightGroupManager type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method CreateGroup Create a new LightGroup object with the given name
Public method DeleteGroup Remove the given LightGroup object from the set of LightGroup objects
Public method Dispose Releases all resources used by the LightGroupManager
Public method GetGroups Get the set of contained LightGroup objects The set of LightGroup objects
Public method GetLightDimmer Gets the dimmer value for the given light for rendering the given view
Public method Static member GetLightGroupManager Creates a light group manager object from the given document
Public method IsLightGroupOn Returns true if the given light group is on
Public method IsLightOn Returns true if the given light is on for rendering the given view
Public method SetLightDimmer Sets the dimmer value for the given light for rendering the given view
Public method SetLightGroupOn Turns the given light group on or off for rendering the given view depending on the bool argument
Public method SetLightOn Turns the given light on or off for rendering the given view depending on the bool argument
Top
See Also