GetHookOrientationAngle Method


Rebar Update Curves Data Get Hook Orientation Angle Method

Note: This API is now obsolete.

Get the termination's rotation angle at end that is currently in the rebar. The angle is used for both hook and crank.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
[ObsoleteAttribute("This method is deprecated in Revit 2026 and may be removed in a later version of Revit. Please use RebarUpdateCurvesData.GetTerminationRotationAngle instead.")]
public double GetHookOrientationAngle(
	int end
)

Parameters

end Int32
The end of bar. Should be 0 for start or 1 for end.

Return Value

Double
The rotation angle at end that is currently in the rebar.
Exceptions
Exception Condition
ArgumentOutOfRangeException Invalid end.
See Also