FilterNumericLessOrEqual Class


Filter Numeric Less Or Equal Class

Tests whether numeric values from the document are less than or equal to a certain value
Inheritance Hierarchy
System Object
Autodesk.Revit.DB FilterNumericRuleEvaluator
Autodesk.Revit.DB FilterNumericLessOrEqual

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public class FilterNumericLessOrEqual : FilterNumericRuleEvaluator

The FilterNumericLessOrEqual type exposes the following members.

Constructors
Name Description
Public method FilterNumericLessOrEqual Constructs an instance of FilterNumericLessOrEqual.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from FilterNumericRuleEvaluator )
Top
Methods
Name Description
Public method Dispose
(Inherited from FilterNumericRuleEvaluator )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method Evaluate(Int64, Int64) Derived classes should override this method to implement the desired test.
(Inherited from FilterNumericRuleEvaluator )
Public method Evaluate(Double, Double, Double) Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not.
(Inherited from FilterNumericRuleEvaluator )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also