SetCrankAngledLength Method


Rebar Bar Type Set Crank Angled Length Method

Sets the crank angled length for the specified Rebar Crank Type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public void SetCrankAngledLength(
	ElementId rebarCrankTypeId,
	double crankAngledLength
)

Parameters

rebarCrankTypeId ElementId
The Rebar Crank Type id. Interactions with Rebar Crank Types can be done with the functions in [!:Autodesk::Revit::DB::Structure::RebarCrankTypeUtils] .
crankAngledLength Double
The new value of the crank angled length.
Exceptions
Exception Condition
ArgumentException The rebarCrankTypeId doesn't represent a valid Rebar Crank Type. It should be an ElementType of BuiltInCategory.OST_RebarCrankType category. -or- For the specified Rebar Crank Type is auto calculated and the cannot be manually set. -or- The crank parameters cannot be computed for the specified crankAngledLength and Rebar Crank Type.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException The given value for crankAngledLength must be positive.
Remarks
When the crank angled length is set, the crank ratio is keeping the same value. The offset length and straight length are adjusted.
See Also