AddPropertySet Method


IFCParameter Template Add Property Set Method

Adds a property set to the template.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public void AddPropertySet(
	PropertySetupType propertySetupType,
	bool exportFlag,
	string propertySetName
)

Parameters

propertySetupType PropertySetupType
The property setup type.
exportFlag Boolean
The flag that indicates whether the property set is included in export.
propertySetName String
The property set name.
Exceptions
Exception Condition
ArgumentException A property set with the given name already exists in the template.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also