GetTemperatureRating Method


Temperature Rating Get Temperature Rating Method

Gets the Conductor Temperature Rating data by given Conductor Temperature Rating id.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public static TemperatureRating GetTemperatureRating(
	Document document,
	ElementId temperatureRatingId
)

Parameters

document Document
The document.
temperatureRatingId ElementId
The Conductor Temperature Rating id.

Return Value

TemperatureRating
The Conductor Temperature Rating data.
Exceptions
Exception Condition
ArgumentException document is not a project document. -or- The id is not a Conductor Temperature Rating id.
ArgumentNullException A non-optional argument was null
InvalidOperationException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
See Also