TemperatureRating Class


Temperature Rating Class

This class represents the definition of Conductor Temperature Rating data.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Electrical TemperatureRating

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public class TemperatureRating : IDisposable

The TemperatureRating type exposes the following members.

Properties
Name Description
Public property Id The Conductor Temperature Rating id.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Name The Conductor Temperature Rating name.
Top
Methods
Name Description
Public method Static member Create Creates a Conductor Temperature Rating.
Public method Dispose Releases all resources used by the TemperatureRating
Public method Static member GetTemperatureRating Gets the Conductor Temperature Rating data by given Conductor Temperature Rating id.
Public method Static member GetTemperatureRatingIdByName Gets the Conductor Temperature Rating id by given Conductor Temperature Rating name.
Public method Static member GetTemperatureRatingIds Gets all the Conductor Temperature Rating ids in the given document, sorted by name.
Top
See Also