Insulation
|
Gets the Conductor Insulation Material id by given Conductor Insulation Material name.
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

public static ElementId GetInsulationMaterialIdByName(
Document document,
string name
)
Parameters
- document Document
- The document.
- name String
- The Conductor Insulation Material name.
Return Value
ElementIdThe Conductor Insulation Material id.

Exception | Condition |
---|---|
ArgumentException | document is not a project document. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- name is an empty string. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). |