InsulationMaterial Class


Insulation Material Class

This class represents the definition of Conductor Insulation Material data.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Electrical InsulationMaterial

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public class InsulationMaterial : IDisposable

The InsulationMaterial type exposes the following members.

Properties
Name Description
Public property Id The Conductor Insulation Material id.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Name The Conductor Insulation Material name.
Top
Methods
Name Description
Public method Static member Create Creates a Conductor Insulation Material.
Public method Dispose Releases all resources used by the InsulationMaterial
Public method Static member GetInsulationMaterial Gets the Conductor Insulation Material data by given Conductor Insulation Material id.
Public method Static member GetInsulationMaterialIdByName Gets the Conductor Insulation Material id by given Conductor Insulation Material name.
Public method Static member GetInsulationMaterialIds Gets all the Conductor Insulation Material ids in the given document, sorted by name.
Top
See Also