GetCrankOffsetMultiplier Method


Rebar Crank Type Utils Get Crank Offset Multiplier Method

Gets the crank offset multiplier value.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public static double GetCrankOffsetMultiplier(
	Document document,
	ElementId rebarCrankTypeId
)

Parameters

document Document
The document.
rebarCrankTypeId ElementId
The Rebar Crank Type id.

Return Value

Double
Returns the crank offset multiplier value.
Exceptions
Exception Condition
ArgumentException The rebarCrankTypeId doesn't represent a valid Rebar Crank Type. It should be an ElementType of BuiltInCategory.OST_RebarCrankType category.
ArgumentNullException A non-optional argument was null
See Also