RebarCrankTypeUtils Class


Rebar Crank Type Utils Class

Utility class for dealing with Rebar Crank Type operations. To find all Rebar Crank Types in the document can be done using FilteredElementCollector of category BuiltInCategory.OST_RebarCrankType.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure RebarCrankTypeUtils

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public static class RebarCrankTypeUtils

The RebarCrankTypeUtils type exposes the following members.

Methods
Name Description
Public method Static member CreateRebarCrankType Creates a Rebar Crank Type element.
Public method Static member GetAllRebarCrankTypes Gets all the Rebar Crank Types elements from the document.
Public method Static member GetCrankLengthMultiplier Gets the crank length multiplier value.
Public method Static member GetCrankOffsetMultiplier Gets the crank offset multiplier value.
Public method Static member GetCrankRatio Gets the crank ratio value.
Public method Static member SetCrankLengthMultiplier Sets the crank length multiplier value.
Public method Static member SetCrankOffsetMultiplier Sets the crank offset multiplier value.
Public method Static member SetCrankRatio Sets the crank ratio value.
Top
See Also