Rebar
|
Gets the termination (e.g hook,crank) rotation angle that is applied to this Rebar at the bar with index barPositionIndex at the specified end.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

Parameters
- barPositionIndex Int32
- An index between 0 and (NumberOfBarPositions-1).
- end Int32
- 0 for the start of bar, 1 for the end of bar.
Return Value
DoubleReturns the termination's (e.g. hook,crank) rotation angle at the specified end.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | end must be 0 or 1. -or- barPositionIndex is not in the range [ 0, NumberOfBarPositions-1 ]. |

If this Rebar has Workshop Instructions set to Straight will return the same value for all barPositionIndex between 0 and (NumberOfBarPositions-1). This value will be the same as Rebar.GetTerminationRotationAngle(int end).
If this Rebar has Workshop Instructions set to Bent there are different cases:
- All bars are matched exactly with a shape. In this case will return the same value for all barPositionIndex between 0 and (NumberOfBarPositions-1). This value will be the same as Rebar.GetTerminationRotationAngle(int end).
- All bars are matched in reversed order with a shape. In this case will return the same value for all barPositionIndex between 0 and (NumberOfBarPositions-1). This value will be the same as Rebar.GetTerminationRotationAngle(int end).
- Some bars are matched in reversed order and the others are matched exactly with a shape. In this case for bars that are matched reversed will return the termination rotation angle at the opposite end. For the others bars will return the same as Rebar.GetTerminationRotationAngle(int end).