GetTerminationRotationAngle Method


Rebar Update Curves Data Get Termination Rotation Angle Method

Gets the termination's (e.g hook, crank) rotation angle (in radians) at end that is currently in the rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public double GetTerminationRotationAngle(
	int end
)

Parameters

end Int32
The end of bar. Should be 0 for start or 1 for end.

Return Value

Double
Returns the termination's (e.g hook, crank) rotation angle (in radians) at end that is currently in the rebar.
Exceptions
Exception Condition
ArgumentOutOfRangeException Invalid end.
See Also