AddParameter Method


Rebar Shape Definition Add Parameter Method

Add a parameter to the shape definition.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public void AddParameter(
	ElementId paramId,
	double defaultValue
)

Parameters

paramId ElementId
The parameter. To obtain the id of a shared parameter, call RebarShapeParameters.GetElementIdForExternalDefinition.
defaultValue Double
A default value for this parameter in shapes. The default values should be chosen carefully, because they are required to be consistent as a set of constraints.
Exceptions
Exception Condition
ArgumentException paramId is not the id of a shared parameter in the current document, or its unit type is not Reinforcement_Length, Angle or Number. -or- The name of a shared parameter identified by paramId was already used by another shared parameter of the element.
ArgumentNullException A non-optional argument was null
Remarks
A shape parameter must be a shared parameter and have value type double. A parameter must be added to the definition before it can be used to drive the shape in a RebarShapeConstraint object. A parameter that does not drive a constraint is legal and will simply become an editable parameter on any Rebar that is an instance of this RebarShape.
See Also