SetTerminationRotationAngle Method


Rebar Update Curves Data Set Termination Rotation Angle Method

Sets the termination's (e.g hook, crank) rotation angle (in radians) at end. This information is set to the rebar after the API execution is finished successfully.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public void SetTerminationRotationAngle(
	int end,
	double angle
)

Parameters

end Int32
The end of bar. Should be 0 for start or 1 for end.
angle Double
The termination's (e.g hook, crank) rotation angle (in radians) at end.
Exceptions
Exception Condition
ArgumentException The given value for angle is not finite
ArgumentOutOfRangeException Invalid end.
See Also