GetDeckProfileId Method


Compound Structure Get Deck Profile Id Method

Retrieves the profile loop used for the specified structural deck.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public ElementId GetDeckProfileId(
	int layerIdx
)

Parameters

layerIdx Int32
Index of a layer in the CompoundStructure. The layer index is zero based. It counts from the exterior of wall and from the top of roofs, floors and ceilings.

Return Value

ElementId
The element id of a FamilySymbol which contains a profile loop used by a structural deck associated to the specified layer, or invalidElementId if isStructuralDeck(layerIdx) is false.
Exceptions
Exception Condition
ArgumentOutOfRangeException The layer index is out of range.
See Also