EndTreatmentTypeIdAtEnd Property


Rebar Shape Terminations Data End Treatment Type Id At End Property

Identifies the end treatement type at the end of the rebar shape. Setting this property to a valid value, will set the HookAngleAtEnd to 0 and HasCrankAtEnd to false.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public ElementId EndTreatmentTypeIdAtEnd { get; set; }

Property Value

ElementId
Exceptions
Exception Condition
ArgumentException When setting this property: endTreatmentTypeIdAtEnd doesn't represent an end treatment type.
ArgumentNullException When setting this property: A non-optional argument was null
See Also